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ABSTRACT

This writing collects some non-trivial information about the preparation of technical docu-
ments in Microsoft Word (version 2002/2003). It’s targeted mainly to people preparing scien-
tific papers, dissertations, technical manuals and other documents of similar nature and
complexity. MS Word isn’t quite optimized for these tasks imposing mainly tools suitable for
quick preparation of short documents while it also has various features for handling longer,
structured documents containing lots of figures, formulas, cross-references, citations, etc. In
thorough textbooks, the descriptions of those features are scattered over hundreds of pages
and hidden within vast amount of other (mostly trivial) information.

The present document (as Word *.doc file) can also serve as a template for certain tasks.
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Introduction

CHAPTER 1. INTRODUCTION

1.1. An overview of word processing and related topics

When using classical typewriter, the typist himself is responsible for imposing proper line and
page breaks in the flow of text. In addition, he must employ multiple spaces and carriage re-
turns to attain desired alignment and spacing of text. When using a word processor, however,
the author is just expected to indicate how the text flow is structured (split into words, sen-
tences, paragraphs, chapters, etc). The software is responsible for text wrapping and pagina-
tion, i.e. breaking the text flow into lines and pages. Furthermore, differently from a plain text
editor (like Notepad) a text processor is usually capable of achieving a pleasing typesetting at
full justification (like the current paragraph) by properly adjusting word spacing and finding
proper hyphenation points. The author can influence the typesetting through the formatting
rules but he should not be concerned about any particular line break.

Typesetting software comes in two flavors: it may be either WYSIWYG (What You See Is
What You Get) or markup-based. In the former case the look of the editable document on the
computer screen is nearly identical to the printout, i.e. the typesetting takes place in real time
as the text is keyed in.” In the latter case, however, the content is typed in a plain text editor
(say, Notepad) and special textual codes are used to designate the structure and formatting of
the document. This text file is then fed to a typesetting engine in order to actually typeset the
document. Well-known markup languages are LaTeX and HTML. Under the hood, a
WYSIWYG software must also utilize some markup but, thankfully, the user seldom needs to
deal with that. The main problem with WYSIWYG text processing is that the software must
sacrifice some quality for the speed. On the other hand, the markup-based systems are fairly
inefficient (unproductive) in preparing short sophisticated layouts involving a high ratio of
formatting (newspapers, magazines, posters, flyers, etc).

There are actually two greatly overlapping kinds of WYSIWYG software: word processors
and desktop publishers. Traditionally, word processing software is primarily meant for
composing documents (i.e. editing and formatting text) whereas desktop publishing software
is intended to finish those documents (i.e. combining the text with accompanying graphics and
performing professional typesetting). However, the distinction is getting increasingly more
blurred. Yet, it is usually ill-advised to use a typical word processor for creating either short
massively sophisticated layouts or extremely long, highly structured documents. Also, due to
the lack of fine spacing and kerning capabilities a word processor is usually unable to produce
the quality typesetting (at full justification) typical to desktop publishers (although for most
people it might be hard to notice the difference [1]). Well-known word processors are MS
Word and OpenOffice.org which though incorporate quite many features of desktop publish-
ers. Examples of high-end desktop publishers are Adobe InDesign and Quark Xpress which
are geared towards layout-intensive work. Finally, there are programs like Adobe
FrameMaker and Corel Ventura which are suitable for creating long structured technical

" MS Word (and most other word processing programs) can switch between different views of the same docu-
ment (check the View menu and the row of small buttons near the lower left corner of Word window). Only in
the Print Layout view Word tries to achieve maximally WYSIWYG display whereas the simplified Normal view
is suggested for routine editing of body text. Normal view does not display page borders, header/footer areas,
floating graphics and other visuals possibly distracting attention of the author. Other than that there is probably
no reason to prefer the Normal view as the computational overhead of the Print Layout view is insignificant for a
typical PC nowadays.
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documents but are a bit inconvenient for short and quick designs. MS Office suite includes
also an entry-level desktop publishing application called MS Publisher.

If one is going to prepare a lengthy document containing /ots of mathematics and /ots of float-
ing graphics, (s)he may need to consider LaTeX as an alternative to WYSIWYG systems [2].
However, unless a good template is provided (by a publisher, university, etc) the detailed con-
trol of the formatting of LaTeX-based documents requires a fair amount of technical informa-
tion. There exist some more-or-less WYSIWYG front-ends for LaTeX (Scientific Word, LyX)
but their effectiveness is arguable.

When a document has been composed and finished in a word processing or publishing soft-
ware, it is then usually converted to a file format (such as PDF, PostScript or XPS) that is
convenient for electronic distribution, printing, viewing on computer screen, or archiving.
Such file format is just supposed to preserve the complete description of a fixed-layout docu-
ment and is not meant for further editing (though minor changes and annotating/commenting
might be possible). Those file formats have freeware viewers available for most platforms.

1.2. Essential rules of text editing in Word

e Pressing signifies a paragraph break in Word and is not meant for adding space
between paragraphs. So press just once to start a new paragraph. The control of
alignment and spacing of paragraphs is the matter of formatting (Format » Paragraph). Spe-
cial alignment of text is achieved by setting proper tab stops (Format » Tabs) or using ta-
bles (possibly with non-visible borders).

e If it is necessary to insert new line within a paragraph, use manual line break
([SHIFTHENTER)). For example, URLs and filenames tend to be so long that you may need to
move them entirely to the next line.

e [f it is necessary to eliminate the possibility of “soft” line break between words, use non-
breaking space (CTRLUHSHIFTHSPACE]) instead of ordinary space to separate the words. For
example, non-breaking space might be sensible when separating the numerical value and
the unit of a quantity (say, 30.48 cm). Similarly, there is a non-breaking hyphen (CTRUH])
that prevents breaking a line at the hyphen. For example, the word CD-ROM should never
be broken.

e Do not use ordinary hyphen (-) to force custom hyphenation of words. Instead, the op-
tional hyphen (CTRLHH) hyphenates the word only if necessary while remaining invisible
otherwise. Optional hyphens are also inserted during the manual hyphenation of document
(Tools » Language » Hyphenation, click Manual).

As an aid for editing, you may sometimes want to switch on the . | ordinary space
display of non-visible (formatting) characters by pressing the but-

ton YL on the toolbar. Each type of non-visible character has dis- | © non-breaking space

tinct display as shown in the table. The display of these characters

is mainly useful for troubleshooting purposes, otherwise they are paragraph break

T_ﬂ

just distracting attention. manual line break

optional hyphen

]

— | tab
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CHAPTER 2. STYLES

2.1. The idea of styles

A style is a named set of formatting attributes that can be linked
to a paragraph (paragraph style) or individual characters ot 7
(character style). Styles accommodate font, indents, spacing, L %
pagination, language used for spell-checking and hyphenation, ~[s=al] [ | sl tieened
bullets & numbering, tab stops, borders & shading. The main Pe<frmating i::;::imng
benefits of using styles follow from the fact that a style is stored | ClarFom 1 ..
separately from the formatted text so that whenever the style is | Equation |4, revesiFomating... |
modified, all linked paragraphs or characters update their look  Heading 1 .
accordingly. Therefore, styles provide a way to separate the con-

Formatting of selected text

tent of a document from the formatting (look), so that the author Hearjfmg 2 )
can just concentrate on writing, and control the formatting of the | Heading 3 !
whole document centrally as needed. In addition, the use of | Nomal ’
styles imposes a discipline in structuring the document (i.e. 1. Numbered List 0
dividing the document into chapters and other logical

subdivisions down to individual paragraphs of body text). For ... [samse omating "

example, one possible route of starting the preparation of a new _. )

. . . Figure 2-1: The Styles and
lengthy document is to first set up the hierarchical structure of Formatting task pane.
the document (using the heading styles) and thereafter fill in the
content. Setting up and restructuring the document is convenient in the outline view (View »
Outline).

Thus, all repeating elements of similar formatting (headings, body text paragraphs, figure cap-
tions, displayed equations, etc) should be linked to common style, and thereafter, all format-
ting of these text elements should be carried out through the modification of the style (i.e. by
avoiding direct formatting options from the Formatting toolbar or Format menu). For example,
in this document all figure captions are linked to a special paragraph style whereas all menu
commands and shortcut keys adhere to a special character style making it easy to centrally
manage their look. On the other hand, there is little point in using styles for formatting the
title page, which appears just once in the document.

Clicking the icon % on the formatting toolbar (or selecting Format » Styles and Formatting)
displays the Styles and Formatting task pane (Fig. 2-1) which is the central place to apply and
manage styles in MS Word.

2.2. Further possibilities to utilize the styles

e Never use blank lines to control spacing between successive paragraphs. This is the matter
of paragraph formatting which is defined as a part of the paragraph style. In particular, the
spacing after heading should be determined by the heading style.

e For the same reason never press to indent the first line of body text paragraph. The
paragraph style should control the indent of the first line. In the future you may want to
modify the amount of the indentation or disable it altogether in favor of an additional
spacing between successive paragraphs. Modifying the style will fix the problem through-
out the document at once.

e You don’t need using [SHIFT| or [CAPS LOCK| to type, for example, chapter title in capital let-
ters. This behavior should be the property of style (check All caps in style’s font settings)
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as you’ll never know when you might want to reconsider this decision. Similar caution is
appropriate for other possible transformations of the font, like SMALL CAPS, shadow, color,
etc.

e Quite commonly, the author wishes to emphasize some terms or phrases in his/her docu-
ment. However, it may not be clear in advance whether the italic, bold or underline
formatting (or some more exotic decoration) will be the most delicate way to catch the
attention of the reader. Therefore, a dedicated character style is necessary. You can em-
ploy built-in styles EMPHASIS or STRONG (they default to italic and bold).

e Instead of defining your own styles from scratch when starting a new document it’s most
efficient and reliable to employ the built-in BoDY TEXT style for body text and the built-
in heading styles (HEADING 1, HEADING 2, etc) for headings. There are a bunch of good
reasons to stick to the built-in heading styles [3]. By default, they are already properly in-
cluded in the table of contents and have convenient shortcut keys assigned. They are also
needed for implementing certain numbering schemes as mentioned in section 5.3.

e In addition to the Normal and Print Layout views, Word has the Outline view displaying
the collapsible and rearrangeable document structure based on the applied heading styles.
This feature comes handy during the designing and restructuring of a long document.

e Styles can be hierarchical (cascading), i.e. a new style can be based on an existing style. If
you do not override a property of the new style it’s inherited from the base style. For
example, when you create a style for a list, it should be based on NORMAL since it usually
has the same font as the ordinary text differing only in the advanced settings for bullets &
numbering (see Chapter 3).

¢ You don’t need a manual page break Paragraph
to start every chapter on a new page. :
The heading style (HEADING 1 or | Indensand Spacing |:
whatever you’re using for top-level ti- || Paamnzten
tles) can accommodate this behavior. || [ den/Orshan contro [ Keep with next
You can also find a number of other et SEte s
useful settings for controlling the Figure 2-2. Pagination properties of paragraph.
pagination of paragraph (see Fig. 2-2).
For instance, heading styles usually have Keep with next checked preventing them remain-
ing at the end of page alone.

e [If a paragraph has incidentally lost its style-specified indents, spacing, alignment, etc,
move the cursor into the paragraph and reset the paragraph ([CTRUHQ). If you have applied
direct formatting to a piece of text (for example, a character style) you can restore the for-
matting in accordance to its paragraph style by selecting the text and resetting the charac-

ters (CTRU}HSPACE).

" Note that NORMAL is active by default when starting a new document and is therefore frequently employed for
the body text. This is usually fine except that it won’t let modifying the body text without possibly affecting
other styles since the NORMAL style is meant to serve as the base of all styles [4].
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CHAPTER 3. FIELDS

3.1. The idea of fields
A field is a placeholder that contains |,

special instructions for working out F"M . —— —— )
the content to display. A field is used | s rower s

to display a piece of text that might | "= |

change from time to time and needs to | =2 A nc

be automatically updated. Word itself | (= &_Lﬂuh —

uses fields for displaying and updat- | i :

. Fage Mo Beld opliors avalabe for S feld
ing the page numbers, the table of | ses

St

contents, etc. As an additional exam- | Seueue:

ple, the date the document was last

saved as shown on the title page of

this document is produced by a spe- | s

cial field. In order to create a field you | == mots o fm s
may use either the Insert » Field com-
mand to browse the list of all avail-
able field types (Fig. 3-1) or just insert
a blank field placeholder (CTRU+[Fd)
and type the proper field codes between the curly braces (then select Update field from context
menu to evaluate the code). For example, the field code that produces the current page num-
ber (in header or footer) looks like { PAGE }. The context menu of a field contains also com-
mand Toggle Field Codes to switch the placeholder between the evaluation result and the field
definition code.

[+ Preserve formatting duning updabes

[ Fied Codes ® || cews

Figure 3-1: Field insertion/editing dialog.

Field codes employ usually various switches to modify their behavior. These switches can be
written directly as part of the field code or conveniently picked from the Insert » Field dialog.
Note that most fields accept \* MERGEFORMAT switch to preserve, during updates, any
direct formatting that has been applied to the field result (the switch is represented by the
Preserve formatting during updates checkbox in Fig. 3-1).

Note that most fields do not update automatically. In order to ensure that all fields in the
document reflect the latest changes, select all text (CTRU+A) and press [F9). In the case of table
of contents (or table of figures, etc) Word asks if only the page numbers or the whole table
needs an update. You may also want to check the Update fields option in the Print tab of Tools »
Options dialog to ensure automatic updating of all fields prior to printing.

If you’re going to distribute or submit your Word document (to a publisher, for example) it
might be advisable to remove all fields and replace them with the most recent evaluation re-
sults as static text by using the Unlink fields command ([CTRUHSHIFTHEY)). In order to distinguish
fields from static text you may want to make a proper selection for Field shading in the View tab
of Tools » Options dialog.

3.2. List of some useful fields

Field code The purpose

{PAGE } Displays the current page number. The field is created, for example,
by the command Insert » Page numbers.
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{NUMPAGES } Displays the total number of pages in the document or current sec-

{ SECTIONPAGES } il}(:n. They cag be used in comblqatlon with { PAGE } to implement

age X of Y” style page numbering.

{ SEQ seqname } Displays the next element of a numeric sequence labeled “seqname”.
The sequence starts with number 1 and is incremented by 1 each
time. For example, it can be used to automatically number figures,
tables and equations as {SEQ Figure}, {SEQ Table} {SEQ
Equation }.

{ SAVEDATE} Displays the date the document was last saved.

{ REF bookmark } Inserts the text represented by the bookmark labeled “bookmark™.
The Insert » Reference » Cross-reference command relies on this field.

{ STYLEREF Displays a recent paragraph text or paragraph number which was

"stylename" }

formatted with the style “stylename”. It can be used to display run-
ning headings, etc.
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CHAPTER 4. OUTLINE NUMBERING

4.1. Creating outline numbered list

A technical document frequently contains outline numbered lists like the following:
1. Text processing software
1.1. Microsoft Word
1.2. Corel WordPerfect
1.3. Sun StarOffice
1.4. OpenOffice.org
2. Desktop publishing software
2.1. Software for short sophisticated layouts
2.1.1. Adobe InDesign
2.1.2. Quark XPress
2.2. Software for long structured documents
2.2.1. Adobe FrameMaker
2.2.2. Corel Ventura
2.2.3. LaTeX

The trivial advantage of using numbered lists feature is the automatic numbering of list items
(so it will be convenient to insert and delete items afterwards with automatic renumbering).
Even more importantly, you can centrally manage the numbering scheme (arabic, alphabetic,
roman, etc), the indentation of list levels, etc.

If special font formatting and paragraph spacing for different list levels is not required, it suf-
fices to create just a single new style for such list (select the body text style as the base style
so that whenever you change the formatting of body text the list will update as well). In the
Modify Style dialog click Modify » Numbering. From the list gallery dialog select a list template
you like (and what is not in use already!). You may not be fully satisfied with the default
numbering settings, therefore click Customize. A fairly sophisticated dialog is opened (be sure
to click the More button on the dialog to see all settings as shown in Fig. 4-1). This dialog is
used to define numbering schemes and alignment for each list level (selected from the Level
list box near the top left corner). The .
numbering scheme is composed in the |Customize Outline Numbersd List (X]

Number format text box. In addition to the | 257", .
counter values (selected with the two | © Corcd |
combos titled Number style and Previous level | “I‘f:":_“"" - =
number) you are allowed to type custom text | Pregs

into the tex‘F box (you may wagt to include ; (o | !

dashes, periods, brackets, etc in the level |, . P

number). Also, for each sublevel tick the | wt v  soedssom 2 F

Restart numbering after check box near lower | e poston P

right corner and ensure that the | herm & pemessooe 4 LLLLLLLL

corresponding combo box displays the

Lirk leved o style: {ree styhe) | L Legal style rumbenng
correct parent level.
Folasy pomber withe Tab charscter bl
The settings in the Number position Eroup | ssusm s ks name: PR e ] wehoke ke =

determine the distance of the left edge, Figure 4-1: Customization dialog of outline numbered list.
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center, or right edge of the list number from the page margin. The indent of the text following
the number is determined by the selection in the Follow number with combo box along with a
corresponding measure in the Tab space after text box. The left indent of the remaining lines of
the list item is determined by the Indent at text box. Note that you shouldn’t try controlling
these indents afterwards by modifying the paragraph format of the style.

Now, to create an outline numbered list, the list style must be applied to a paragraph which
thereafter becomes a top-level list item. Pressing creates the following list item at the
same list level as the current one. While the cursor is placed immediately after the item num-
ber, pressing moves the item one level down (increases indent) whereas [SHIFTHTAB| does
the opposite.

By default, all paragraphs with the same numbering style are supposed to belong to the same
list and are numbered continuously throughout the document. The most straightforward way
to start a new list (employing the same list style) is to right-click on the number of the first
paragraph of the new list and select Restart Numbering from the context menu (note that there
is also Continue Numbering command available although [CTRUHQ| (Reset Paragraph) is recom-
mended to achieve the same result). A more reliable but also more inconvenient method is to
place a LISTNUM field at the end of each list. For a single level list, the appropriate syntax is
{LISTNUM \s 0} You can format the field using either white or hidden font to make it
invisible when printing. For further possibilities, check Ref. [5].

4.2. Creating numbered headings

Multilevel numbering of headings is set up essentially in the same manner as that of a list; you
just need to link each list level to the corresponding heading style (Link level to style combo
box in Fig. 4-1). Depending on the document you may want to include the words “Chapter”,
“Section”, “Appendix”, etc in the number of a title; you need to type this word into the
Number format text box. It is suggested that you access the Customize Outline Numbered List dia-
log always from the Modify Style dialog of HEADING 1 [6].
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CHAPTER 5. FIGURES

5.1. Preparing figures for Word

Usually it’s best to prepare high-quality graphics in dedicated software other than MS Word.
From the image-editing program you need to save or export the image in a format that Word
can later import. Photographs (and drawings that make a massive use of gradients) are best
saved in JPEG format. Vector graphics should be stored as EMF (Enhanced Metafile) which
is a native vector format of Windows (and MS Office). In some cases you might not have ac-
cess to the original vector representation of a drawing or the EMF export filter might malfunc-
tion. In that case the drawings should be saved in a lossless raster format, since the lossy
JPEG compression introduces artifacts whenever sharp transitions are present in the image.
PNG and GIF provide a good compression and wide support but GIF is limited to only 255
colors.

Frequently the source of an image is a document in PDF format. Use the Snapshot tool of the
PDF reader to copy a screen area as raster image into clipboard. The resolution of the copied
image is determined by the resolution of your monitor and the size of the selection rectangle.
In documents related to computing, screenshots of some software are frequently incorporated.
Press |ALT[HPRINT SCREEN| to capture the image of active window or dialog box into clipboard
(PRINT SCREEN| alone captures the whole desktop). For more specialized tasks, use a screen
capture utility like MWSnap [7].

When preparing a raster image for inclusion in a Word document pay attention to the resolu-
tion (number of pixels). The resolution should be sufficient to yield a pleasing appearance on
the printed page but it would be pointless to incorporate a maximum-resolution photograph
(say, 3200%2400) from a digital photocamera. Use a tool

like IrfanView [8] to reduce the image resolution (and/or

perform cropping) if necessary.

It is usually preferred (at least for large images) to insert the
image from a file instead of pasting from clipboard as Word / READ N /
maintains the compression that is present in the original file.

Never copy and paste large photos leading to bloating file SET
size; use dedicated software (like IrfanView) to prepare a SET
properly compressed JPEG file.

m=
I
i

The drawing tools provided by Word are sometimes suffi-
cient for creating simple technical schemes and diagrams. SET F=F*M
Word also provides a special drawing canvas which keeps
the drawing primitives (lines, shapes, textboxes, etc) to- false
gether and provides a boundary between the drawing and p———— @
the surrounding paragraph text (see Fig. 5-1). By default a

new drawing canvas is created if you’re trying to place a true

drawing object but no existing drawing canvas is selected
(the behavior is set in the Tools » Options » General dialog). / PRINT F /

5.2. Positioning and captioning figures END

Follow these steps to create a captioned figure in a Word Figyre 5-1: Calculating the factorial of N.

document: The diagram is drawn on a drawing

.- . canvas by using the drawing tools pro-
1. Position the cursor into an empty paragraph. vided by Word.
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Put an inline image into the paragraph. Insert the image from a file (Insert » Picture » From
File), paste from the clipboard (Edit » Paste Special), or create a drawing canvas (Insert »
Picture » New Picture) and draw a diagram using the drawing tools provided by Word.

Press to create a new paragraph beneath the image and type a caption for the figure.
Use a special style for the caption to grant the possibility of creating the list of figures if
needed (see page IV as an example) and centrally control the text formatting in the future.
There is a built-in style CAPTION meant for the purpose (note that the numbering proce-
dure, described in the next section, automatically applies this style).

If you don’t need that the text freely flows past the figure (as it does in professional lay-
outs), then all you need to do is to click on the figure, select Format » Paragraph, go to Line
and Page Breaks tab, check Keep with next. That ensures that the paragraph containing the
figure stays always on the same page as the following paragraph holding the caption (for
convenience, you may define for figures a special style enforcing this property). In addi-
tion, the style of the figure caption might need to have Keep lines together checked in para-
graph settings to avoid breaking the caption across pages.

However, if you would like to create a floating image (like Fig. 5-1), select the image
along with its caption and, on the Forms toolbar, click Insert Frame (you may want to add
this command to some other toolbar or the Insert menu for quicker access). By the way,
you can’t use textbox instead of frame because in that case Word seems incapable to in-
clude the caption in the table of figures (it is said that Word looks for the captions in the
document layer, which the frame is part of, whereas textbox belongs to drawing layer).
Double-click on the border of the frame to display Format Frame dialog. Set Text Wrapping
to Around. Set Height (and possibly also Width) to Auto so that the height (width) of the
frame is adjusted to fit to the image and the caption. Set horizontal and vertical position as
necessary. Usually you want the figure to align horizontally to the left or right margin and
vertically to the top or bottom margin. You may also align vertically relative to the para-
graph the frame is anchored to.” Check Move with Text to make sure the figure will be mov-
ing with the paragraph it is anchored to. You can anchor the frame to a different paragraph
by dragging the anchor symbol in front of the paragraph (if the anchor is not visible, you
must check Object Anchors on the Tools » Options » View dialog).

For space-conserving and
aesthetical reasons you
may want to setup multi-
ple figures side-by-side or
one above the other. For
that purpose (and also as
an alternative to the use
frames) you can use a ta-
ble reserving a cell for
each figure with its cap-
tion. Note that you should
not allow breaking the row  Figure 5-2: An artistic view of Earth.”  Figure 5-3: Photo of Earth by Apollo 17.
across pages (Table » Table
Properties, sheet Row).

" You can also insist the horizontal or vertical position be just inside margins, but Word might not be smart
enough to make reasonable decisions on the placement of figures. As far as I can tell, there is no possibility to
achieve such robust figure/table positioning behavior available in LaTeX.

"'S. Budig, How to make “cool” globes with the GIMP, http://www.home.unix-ag.org/simon/gimp/globes.html.
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5.3. Numbering and referencing figures

Automatically numbered captions for figures and tables are created with the Insert » Reference
» Caption dialog. Unsurprisingly, the number produced by the command turns out to be a SEQ
field, for example { SEQ Figure } or { SEQ Table } or { SEQ Equation } depending on the
label selected. This field produces a sequence of integral numbers as mentioned in section 3.2.
Furthermore, in the Insert » Reference » Caption dialog (click button Numbering) you can insist
that current chapter number be included as the prefix. This is indeed the style used in longer
structured documents (see figure captions of the present document as an example). That
composite number is produced by the combination of two fields as follows:
{ STYLEREEF 1 \s }-{ SEQ Figure \s 1 }. The STYLEREF field is producing the number of
the most recent level 1 title (i.e., HEADING 1). The switch \s in the field code is actually not
documented; it causes the field to display only the number of the heading without any text
(like Chapter or Appendix) that might also be defined as part of the numbering. The “\s 1”
code in the SEQ field forces the restart of numbering whenever the level 1 style (e.g.
HEADING 1) is encountered. Altogether, this algorithm produces figure numbers similar to
those used in this document. Note that the use of the Insert » Reference » Caption feature
automatically applies built in CAPTION style to the paragraph.

MS Word provides the Insert » Reference » Cross-reference command for create a cross-refer-
ence to various parts of the document. However, the referencing capability appears to have a
serious limitation: referencing the number only is not possible (for example, you are forced to
say “see Figure 3” instead of “see fig. 3”). Fortunately, the limitation is easy to overcome by
placing a bookmark enclosing the text to be referenced.” Mark the figure number, select Insert
» Bookmark and give the bookmark a unique and meaningful name (to make it easy to recog-
nize later). Then go to the point in the document where you would like the reference to appear,
click Insert » Reference » Cross-reference, select Bookmark from Reference type, select Bookmark
text from Insert reference to, and finally select the name of the bookmark. It is usually benefi-
cial to check Insert as hyperlink making it easy to navigate the document. You may ascertain
that this procedure actually creates a REF field. This field accepts the switch \h to behave as
hyperlink.

Note that after placing the bookmark you must be careful in the modification of the text
nearby. If you insert some text just before or just after the bookmark you won’t know if it
becomes enclosed within the bookmark or not. If things go wrong you just have to reinsert the
bookmark (with the same name).

" The existing functionality is also based on bookmarks but these bookmarks are hidden and not meant to be
controlled by the user. These hidden bookmarks usually enclose both the label and the number making it
impossible to reference the number alone.
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CHAPTER 6. EQUATIONS

Handling of math in Word involves a number of problems: how to create, align, number and
reference equations, and what formatting style is appropriate to use.

6.1. The style of equations

The style used for writing equations is somewhat a matter of personal taste and traditions of
the scientific discipline the writer is representing. Still, professional publications adhere to
some widely accepted math and physics traditions which are supposed to improve the aesthet-
ics and readability of the text.

Font size should match the surrounding paragraph text.

Alphabetical symbols denoting variables, physical quantities, etc, are set in italics (x, y, a,
p). Capital Greek letters are an exception being usually written in upright (®, A).

Numbers and normal text (including textual subscripts) are in upright letters. This applies
also to units of physical quantities, symbols of chemical elements, symbols of elementary
particles, etc. Example: Vioeket = 8000 m/s (note that there is a space between the numeri-
cal value and the unit).

Function names (sin, log, ...) and mathematical operators (summation and integral signs,
etc) are set in upright letters.

Multiplication symbol (- or X) is used only in some special cases, for example when denot-
ing numbers in scientific notation (e.g. 1.98x10**). In equations it is usually omitted.
Sometimes people utilize even the asterisk symbol (*) to denote multiplication although
the symbol is meant to serve only in computing and programming languages (see Fig. 5-1
for an example) and not in ordinary math. The same applies to symbols like >=, <=, and
<>, which are normally written as >, <, and #.

The hyphen (-) is not the minus sign (-) and looks unaesthetic in this role. The minus sign
is usually designed to be the same length as the plus and equals signs. En-dash may be
used as a minus sign.

The brackets are set in upright font. The size of brackets should match the enclosed con-
tent (equation editors have usually special vertically “stretching” brackets for that pur-
pose).

Although in handwriting, vector quantities are designated by an over-arrow (or a bar), it is
more common to apply a bold style in printed documents.

Compact math expressions and equations that will not be referenced elsewhere in the
document should be embedded (inline) within a paragraph (e.g. y = ax™+b). For inline
equations the fractions of the form a/b are preferred over stacked style 2.

As an example, formula 6.1 is written in accordance to these rules whereas formula 6.2 is not.

B —b+b? —4dac

xl’z = 22 (61)
b bZ-4*a*c
x| = VD HAE (6.2)
1,2 2%
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If you use the Equation Editor included with Word, it’s usually best to use its default settings,
which automatically match the surrounding text and mathematical tradition.

6.2. Aligning and numbering equations

Aligning a displayed equation and its number (as in the examples above) is fairly simple by
defining a special style for that purpose. Create a new style (based on normal body text) and
set two tab stops for it — one for positioning the equation and another for aligning its number.
In the present document, for example, the first tab stop is at 8 cm centered whereas the second
tab stop is at 15.5 cm right-aligned (Eqns. 6.1 and 6.2). Now that you have the EQUATION
style defined, create an empty (single-line) paragraph and set its style to EQUATION. Press
once. Enter the equation. Press [TAB| once more. Enter the number for the equation. The
numbering and cross-referencing of displayed equations can be implemented in exactly the
same manner as in the case of figures (see section 5.3). However, the Insert » Reference »
Caption feature automatically applies the built-in CAPTION style to the paragraph which is to-
tally pointless here. You may want to employ a macro that does the same job of creating the
combination of STYLEREF and SEQ fields (see Appendix B).

As an alternative to tab stops, you can use a table (with invisible borders) for equation align-
ment [10]. This might be necessary for displaying a large equation in a multicolumn layout.

6.3. Creating equations

In general, there are three (fairly different and inconsistent) ways to create math in a Word
document. Equation Editor (or its professional version MathType) is generally the preferred
tool for the purpose. However, it is reasonable to create simplistic inline expressions (like
E =mc*, etc) just by direct formatting of normal text (applying italics, bold, sub- and super-
script as necessary) and using Insert » Symbol for obtaining special symbols. Finally, Word has
the EQ field, which allows (in combination with direct formatting) creating some simple math
constructs like /a2+b2 , but I can hardly see any practical use for this approach unless you
can’t get Equation Editor running.

Note that Word 2007 has completely redesigned (and arguably better) approach to equation
editing and handling. In Word 2007, equations are written using a LaTeX-derived notation
and they are more natural ingredients of the text. The old-fashioned equation editor is also
available, though.
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CHAPTER 7. HANDLING BIBLIOGRAPHY

Scientific papers, dissertations and monographs have frequently lists of references or
bibliographies containing hundreds or even thousands records. There are two main citation
styles: author-year or numerical. In the latter case all references are sequentially numbered
and it’s hardly imaginable to manually update this list and the corresponding citations scat-
tered all over the document. For bibliography numbering, one can employ the SEQ field
(quite fool-proof and flexible), a numbered list (a bit more convenient but more fragile and
not so flexible), footnotes/endnotes (a quick and dirty way to get the job done) or dedicated
reference management software (by far the most complete solution).

7.1. Footnotes and endnotes

The simplest solution appears to be using footnotes or endnotes (Insert » Reference » Footnote).
Unfortunately, there is no consistent way to cite a bibliography item more than once. A cheap
trick is to create a cross-reference to an existing citation (Insert » Reference » Cross-reference,
select Footnote from Reference type). The formatting of footnote/endnote text is controlled
through the internal styles FOOTNOTE TEXT/ENDNOTE TEXT whereas the number formatting is
determined by FOOTNOTE REFERENCE/ENDNOTE REFERENCE. It is also possible to remove the
horizontal separator line that Word automatically places between the list of notes and the
main text. In the Normal view select View » Footnotes; this opens a special note pane near the
bottom edge of the window. Select Endnote separator from the combo box near the top of the
pane and delete the horizontal line.

7.2. Numbered list

The Insert » Reference » Cross-reference tool allows referencing any numbered paragraph
whether it is a heading or a list item of the body text. Therefore the numbered list can be used
to implement the list of references. To reference a list item, click Insert » Reference » Cross-
reference, select Numbered item from Reference type, select Paragraph number from Insert
reference to, and finally select the bibliography record you want to cite. There appears to be
one limitation, though. If the list is customized such that the number is enclosed in brackets,
then you are unable to cite multiple sources at a time. For example, if the list goes as [1], [2],
[3], etc, then you can’t cite like [2, 4-7, 9]. Nevertheless, this document relies on this ap-
proach due to modest citation requirements (see page 23).

7.3. SEQ field

The use of SEQ field seems to be the most flexible route for handling references (if relying on
the built-in features of Word). Therefore you need to start each bibliography record with
something like { SEQ reference }. It may be advisable to create a special style for references.
You can employ the paragraph’s first line (hanging) indent and left indent in combination
with a tab stop to implement something that looks like a list.

7.4. Dedicated reference management software

Specialized database software exists to collect and manage bibliographic records [12]. In
addition, such programs have the very useful ability to import records from web-based data-
bases and other sources, and to instantly format the records in accordance to any specified
citation style. Custom styles are easy to set up. The software integrates with word processors
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(through the use of macros, etc) and fully controls the citing as well as the list of references in
the document (citations and references are both implemented as fields to enable their auto-
matic update). With a few mouse clicks a different citation style can be applied (to suite for
the requirements of another journal, for example). A fairly popular commercial package
seems to be EndNote [13] whereas quite decent freeware solution is Zotero [14].

Note that Word 2007 has a promising new feature to handle the references, although it’s still
lacking some essential abilities of dedicated software (importing and exporting records, creat-
ing custom citation styles, etc).
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CHAPTER 8. MISCELLANEOUS TASKS

8.1. Copying and pasting data from other applications

When you’re copying-pasting data from another application supporting rich text formatting
and multiple image formats (web browser, PDF viewer, e-mail client, etc), Word tries to pre-
serve as much of the original formatting as it can. However, this formatting is rarely what is
needed as it does not adhere to the styles that were set up in the Word document. You can do
one of the following:

e Use Edit » Paste Special instead of Edit » Paste. In the dialog box that appears, select
Unformatted text from the list box to remove any formatting (and graphics) and preserve
just the raw sequence of characters (for handling figures, see
Chapter 5). B -

e If you have Show Paste Options buttons checked in the Edit tab of | =° sewresremating

. . (' Match Destination Formatting
Tools » Options dialog, you may paste the text as usual. Then an
icon like 5=l appears just after the pasted text. After clicking on
that icon a drop-down menu appears containing various paste op-
tions as shown in figure 8-1. Match destination formatting or Keep
text only are the most fool-proof choices. Keep text only should be
similar to Edit » Paste Special » Unformatted text.

' Keep Text Only

fﬁ Apply Style or Formatting...

Figure 8-1: The Paste
Options button.

It may still happen that the pasted text contains a number of excess line breaks. At this point it
is useful to make various non-printing formatting characters in your document visible by
clicking the button L. on the toolbar. There are two kinds of “hard” line breaks in Word:
paragraph breaks (indicated by a ¥ symbol) and manual line breaks (indicated by a + symbol).
While a few unwanted line breaks are easy to fix manually, longer texts may require more
serious means of attack. Usually it’s possible to get rid of the excess paragraph breaks by just
applying AutoFormat to selected text (Format » AutoFormat » AutoFormat now). In general,
however, the replace tool (Edit » Replace) may become handy. In the replace dialog, press More
to see some advanced options (Fig.
8-2). Position the cursor into the Find
what textbox. At the bottom of the
dialog, there is button labeled Special.

Find and Replace

Find Replace | GoTa

After clicking on it a list of special | ™" e e
(incl.  non-visible) characters is | .- =
displayed. For example, you can se- || ' —
lect Paragraph Mark or Manual Line e e e e
Break, which are inserted into the text- || searchoptions

Search; ;AII v

box as special codes *p and "l (YOU | Fumencose

may type the codes yourself). Into the B s

textbox Replace with type a space. | [Osouncslie Endish)

Then either press Replace All or play _Rga:‘end R s oo )

with Find next and Replace to confirm (Fomet~ ] [Cspesal~ ]
or reject each case individually. Simi-
larly, empty lines (e.g. "Il) may be
converted to paragraph breaks, multi-
ple consecutive spaces to single space, non-breaking space to ordinary space, etc.

Figure 8-2: The Find and Replace dialog.
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8.2. Sections and page numbering

You can divide a Word document into any number of sections. Each section can have differ-
ent settings for paper size and orientation, margins, columns, headers & footers (incl. page
numbering). To create a new section, execute Insert » Break and select a proper type of section
break in the dialog. A newly created document consists initially of just one section. The mark-

ings of section breaks are toggled by pressing the button - on the toolbar.

Note that Word sections have nothing to do with the logical division of the main text into
parts, chapters, paragraphs, etc (and the sections, subsections, etc as used in LaTeX). Differ-
ent sections might be useful, for instance, for separating front matter (title page, table of con-
tents, preface) and body (main text) of a book.

A page number in Word is nothing but a field inserted usually into the header or footer area of
the page. Each section can have different page numbering scheme (and header/footer contents

in general). The number of a page within a section is determined by a starting value (usually 1)
and the location of the page in the section. Note that the values of page numbers do not de-

pend on whether they are actually displayed or not.

Although Word provides Insert » Page Numbers command, a more robust and cleaner approach
is to setup header/footer content manually. Execute View » Header and Footer to switch editing
to the header/footer area. Position the cursor where you want the page number to appear and
insert the field {PAGE} to display the page number. Related useful fields are
{ NUMPAGES } and { SECTIONPAGES }, which allow implementing “Page X of Y” style
of numbering. There are various more sophisticated (albeit seldom needed) tricks you can do
with the fields related to page numbering [11].

Note that you have a quick access
to all the fields as well as to other
relevant tasks through a special I3
toolbar which appears as soon as Incert Page Number (Alt+shift+) |

you activate the editing of Figure8-3: The Header and Footer toolbar.

header/footer (Fig. 8-3). In order to

change the starting value of the page numbers for the current section, click the Format Page
Number button. You have the option to continue the numbering from the previous section or
type the desired value in the Start at textbox. Furthermore, the same dialog provides a
possibility to modify the numbering scheme (arabic, alphabetic, roman).

Insert AutoText = | H | e | B3R E (TS, | dose

Finally, note that by default the layout of headers and footers of all sections are the same be-
cause the sections are /inked. You can link or unlink sections by toggling the Link to Previous
button.
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8.3. Customizing the table of contents

Table of contents is a TOC field that is
conveniently created through the Insert »
Reference » Index and Tables » Table of | Index |

| Print Preview Web Preview

Index and Tables

L Table of Figures | Table of Authorities

Contents dialog. The depth of titles to be : o) : &
shown in the table of contents is deter- Heading ;_Id ...... P ; - Headmg;l s
. gadmg ~... ... eading -
mined by the Show levels value. The look Heading 3 5 Heading 3
of the table of contents is controlled by
the built-in styles TOCI, TOC2, ..., 4 [l
Show page numbers Use hyperlinks instead of page numbers

corresponding to levels 1, 2, ..., respec-

. . Right align page numbers
tively. For example, the common right- :

aligning of the page numbers (with a G;?:'r:ader“' """" =

leader dotted line) is achieved by setting || Fomats: |Fron tempete [v|  shonlevels 3 &

a proper tab stop. These styles are usu- || [[ShoxoutinngTodbar ] (Loptiens... ] [ todiy... ]
ally not visible in the Styles and o) [Lcne ]

Formatting task pane, but you can easily
access them by opening Insert »
Reference » Index and Tables » Table of
Contents dialog and pressing the button Modify located at the lower right corner. However, it
seems that automatic update is enabled for the styles by default so that any direct formatting
of the table of contents entries should modify the styles correspondingly. If necessary, table of
contents based on any styles (not just the built-in heading styles) can be set up by clicking the
Options button.

Figure 8-4: The dialog for setting up table of contents.

8.4. Creating appendices

The problem with appendices is that they are usually subject to a different type of numbering
scheme than the main headings, such as Appendix A, Appendix B, ..., instead to Chapter 1,
Chapter 2, .... Therefore you can’t employ HEADING 1 for that purpose. A common solution is
to exploit a heading style that is not in use for titles in the main part of the document, say
HEADING 7 (it is very improbable that you need so deep nesting of titles, therefore this style
should be unemployed).

1. From the Modify Style dialog of HEADING 1, select Format » Bullets and Numbering and click
Customize. In the Level list, click 7. In the Number format box, type Appendix and press
SPACE|. From the Number style list select A, B, C, .... Click More. From the Link level to style
list select Heading 7 and click OK. You may also play with the alignment options. Finally,
modify the font and paragraph settings of HEADING 7 style as appropriate. For example, if
you want the appendix titles look exactly like HEADING 1 (as in this document), you may
take HEADING 1 as the base style.

2. In order to incorporate appendices into the table of contents, open the Insert » Reference »
Index and Tables » Table of Contents dialog and click Options. To show HEADING 7 titles in
table of contents at the same level as HEADING 1 titles, type “1” into the TOC level box to
the right of Heading 7 in the Available styles list. Clear the Outline levels check box. Click OK
twice.

3. If you would like to change figure, table or equation numbering scheme to include appen-
dix number, you need to modify the STYLEREF and SEQ fields accordingly to reference
level 7 headings (see Fig. A-1 in Appendix A).
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CHAPTER 9. INCREASING PRODUCTIVITY

MS Word has a fairly well-designed user interface which supports nearly unlimited

customization. You can:

[ ]
Customize, click Keyboard button).

Customize and reorganize menu items and toolbar buttons (Tools » Customize).
Create macros for automating lengthy but frequently required tasks (Tools » Macro).
Associate custom keyboard shortcuts with commands, macros and styles (Tools »

Define useful AutoCorrect rules (Tools » AutoCorrect Options).

If you have customized Word a lot, you may want to use the Save My Settings Wizard (in-
cluded with MS Office installation) to store the workspace in a file. When you need to rein-
stall the application you can then easily restore your customizations.

9.1. Customizing the workspace

As the first step, you can somewhat optimize
the layout of the workspace. Just after installa-
tion you may need to adjust the placement of
toolbars so that all buttons become visible on
the screen (hover the mouse pointer above the
left edge of the toolbar so that it will turn into
a four-headed pointer, then click and drag the
toolbar). Technically minded people may want
to include additional buttons for Superscript,
Subscript, Insert Equation, Insert Symbol, etc. For
that purpose, right-click on the toolbar area
and select Customize. Then, on the Commands
tab, find the commands of interest and drag
them on the desired location on any toolbar
(Fig. 9-1). There is even more convenient

=5 Mew Roman -~ 12 .|B I U x éE EEH:
-z-l-L-|-§-|-1-|-2-3-|-4-|-5-|

Customize

=
X

Toolbars | Commands | Cptions
To add a command to a toolbar: select a category and drag the

command out of this dialog box to a toalbar.
Cateqgories: Commands:
File
Edit
View
Insert

| | &80 Small Caps

& Al Caps

Format x* | Superscript

Tools
Table
Web

X,

Subscript |
Hidden

Figure 9-1: Dragging additional commands onto the
toolbar.

route to toggle the visibility of buttons: click on the downward arrow on the right edge of the
toolbar and select Add or Remove Buttons. For example, you may want to remove surplus com-
mands like Cut, Copy, Paste, Undo, etc, which are better accessed by a hotkey.

Alternatively, you may backup the

Normal.dot

template which should be located at

%APPDATA%\Microsoft\Templates (type the path into Windows Explorer address bar).
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9.2. Using and customizing hotkeys

In a text processing application (as opposed to a CAD program, for Save | CTRUHE
example) the rational use of keyboard is the main way to increase
productivity as the routinely used text editing and navigational com- Undo | [cTRUHZ
mands do not assume precise pointer movement on screen and it’s al-
: . Cut | [cTRUHM
ways more time-consuming to hunt the commands from menus or tool-
bars with the mouse. The hotkeys shown to the right are so widely Copy | [cTRUH(d]
recognized on PC platform that nearly all well-designed applications
& p y & PP Paste | [CTRUHV
support them.
You will also find the following editing and navigational shortcuts very | Select All CTRLHA

useful in MS Word:

Special characters and formatting marks

En-dash

[CTRU+(NumPad)H

Non-braking space

[CTRLIHSHIFTHSPACE]

Non-braking hyphen

[eTRLH]

Optional hyphen

CTRLHH

Manual line break

[SHIFTHENTER

Page break

[CTRUHENTER

Navigational commands

Previous/next word

[CTRLHLEFT/RIGHT]

Previous/next page

[CTRUHPAGE UP/DN|

Beginning/end of document

[CTRLHHHOME/END|

Zoom in/out | [CTRLHHMOUSE WHEEL]

LEFT
[SHIFTHF

Go back (after clicking a hyperlink)

Previous editing location

Formatting

Italic

Bold

CTRUH]
CTRU+HE]
CTRUHU
CTRLHSPACH]
cTrL}+d
[sHIFTHFS
[CTRUHSHFTHN
[CTRU+SHIFTH

Underline

Reset character

Reset paragraph

Change case

Apply NORMAL style

Set focus to Style combo box

Fields
Insert field

CTRUHF9)

20



Increasing productivity

Update field

In addition, I would suggest assigning handy shortcuts to commands such as Redo, Subscript,
Superscript, and Insert Bookmark. In order to assign/modify hotkeys, open the Customize dialog
(as explained above) and click the Keyboard button at the bottom of the dialog. Select the com-
mand, then move the focus to the textbox labeled Press new shortcut key and press the desired
combination of keys, and finally press Assign. Note that Word automatically handles the
possibility that the hotkey might already be assigned to another command (no need to remove
the previous assignment).

In most applications, Save ([CTRUHS]) and Undo (CTRUHZ) are your best friends. To minimize
the possibility of losing work due to unexpected system failure, develop the habit of pressing
whenever you’re making a pause in editing. Pressing [CTRUHZ is a quick way to re-
verse the last action. The maximum number of undo levels in Word is allegedly limited by
system resources only (not true for the other programs in the office suite) meaning that you
may fairly confidently experiment with editing and recover the initial state if situation is get-
ting out of control. There is even matching multi-level Redo to reinstate accidentally undone
actions. If you click the downward arrow next to the Undo (or Redo) button on the toolbar, you
will get a detailed list of all undoable (redoable) actions. This provides a convenient way to
undo (redo) a great amount of editing at once. Understandably undo and redo capability is
limited to current editing session only.

9.3. Macros

If you’re preparing a lengthy document, you’re definitely going to repeat some series of ac-
tions for a number of times (like creating a figure number using the SEQ and STYLEREF
fields, etc). In that case you should record the series of actions as a macro (Tools » Macro »
Record New Macro) and assign a toolbar button or a shortcut to the macro. In order to make
smart, convenient and error resistant macros you might need to manually edit the macro code
using Visual Basic editor (Tools » Macro » Visual Basic Editor). Initially record the macros close
to what you would like to implement and later in the code editor try to decipher and modify
the macro code that Word creates. It seems to be a faster way to get started than trying to code
the macros from scratch by learning the VBA scripting language. The macro editor is also
quite convenient due to “Auto List Members” feature and context-sensitive help. Some useful
macro examples are collected in Appendix B.

9.4. AutoCorrect

The AutoCorrect feature (Tools » AutoCorrect Options) z -
allows Word to automatically respond to specific input |
patterns. It usually operates in the background to correct |
some typing errors b}lt f.rom the teghnlcal point of View [ Autocorrect Optons... I
it can be used to easily insert special characters (for in-

stance, transforming the character sequence --> into an Figure 9-2: AutoCorrect options button.
arrow —). Furthermore, you may attribute convenient

abbreviations to some frequently encountered complicated phrases, like “Schrodinger equa-
tion” or “Hertzsprung-Russell diagram”, etc. If Word applies an AutoCorrect rule you didn’t
expect just press [CTRU+Z or [BACKSPACE| In addition, an icon like [Z -l appears just beside the
location where AutoCorrect was applied. Clicking the icon reveals a menu where you can find
a proper command to permanently disable an annoying AutoCorrect rule (see Fig. 9-2).

Undo Automatic Capitalization

Stop Auto-capitalizing First Letter of Sentences |
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9.5. Equation Editor

If you’re doing a lot of math work and using Equation Editor, you can do the following:

Word has a special command to launch Equation Editor; you just have to customize the
toolbar (or menu) to include the command (otherwise you have to use the inconvenient In-

sert » Object route).

Equation Editor has a hidden setting to force it open
in a separate window (which makes the editing
more convenient). You need to open the registry
editor, navigate to
HKEY_CURRENT_USER\Software\Microsoft\Equation

Editor\3.0\0ptions\General (this registry key will be
present only if you have run Equation Editor at least
once on that computer) and set the string value
ForceOpen to 1.

Memorize the hotkeys of most frequently used com-
mands. Note that Equation Editor does not display

Fraction | [CTRU+H

Superscript | [CTRUHH

Subscript | [cTRUHY

Square root | [CTRU+R]
“Stretching” parentheses | [CTRUH9
Insert vector variable | [CTRUHg]
Insert Greek letter | [CTRUHd

the shortcuts (or allow customizing them); you have to consult the help file.
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Various MS Word tips and tricks

APPENDIX A. VARIOUS MS WORD TIPS AND

TRICKS

For easier navigation in long documents you should consider the document map (View »
Document Map) which provides a quick hyperlinked table of contents of the document
based on the titles which have the built-in heading styles assigned [15].

The split view (Window » Split) gives you two different views of the same document and
might be useful for comparing or copying of text from different parts of the document.

MS Word keeps track of the last three locations where the
document was edited. Press [SHFTHFS to go back to the
previous editing location. You may also press [SHIFTHF]
immediately after opening the document to resume editing
at the location where you last made a change.

In order to select rectangular columns of characters hold
down while dragging the mouse. This feature might be
useful for trimming leading spaces from pasted text, etc.

Word permits selecting multiple, noncontiguous blocks of
text. Just hold down |CTRL when selecting the pieces of text.

To reveal complete formatting information about some part
of the document, issue Format » Reveal Formatting ([SHIFT}+[F])
and select the text you are concerned about. To determine
the formatting source (whether the formatting is due to a
style, etc), mark the Distinguish style source check box.
Might be useful for troubleshooting purposes.

The MS Word executable (C:\Program Files\Microsoft
Office\Office\Winword.exe) accepts a number of command-
line switches to modify the startup behavior. The switch /a
prevents Word from automatically executing any macros
stored in the Normal.dot template. The switch /n prevents
creating a new blank document at startup. The switch
ImMacroname asks Word to execute the macro called
“Macroname”. For example, the built-in macro Filel loads

Selected text

fsHiET

[] Compare to another selection

Formatting of selected text

=] Font ps
From Character Style: Hotkey
Character Style:

Hotkey
Font:

Arial Narrow

10 pt

Bold
Effects:

Al caps
Borders:

Border: : {Single solid line, Auto, 1 pt)

El Paragraph
From Paragraph Style: Bulleted List
Paragraph Style:
Bulleted List
Alignment:
Justified
Indentation:
Left: 0cm
Hanging: 0,63 cm
Right: 0cm
Tabs:
Tabs: 0,63 cm, List tab

E Bullets and Numbering
Qutline numbered
Level: 1
Numbering Style: Bullet
Aligned at: 0cm
Tab after: 0,63 cm
Indent at: 0,63 cm b

Options

Distinguish style source
] show &ll formatting marks

the most recently used document. Figure A-1: The Reveal Formatting

task pane
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Some useful macros

APPENDIX B. SOME USEFUL MACROS

If you would like to create Zoom In and Zoom Out buttons on a toolbar, you would need these
macros (replace the 10% with the amount of zoom you would like):

Sub ZoomIn()
With ActiveWindow.ActivePane.View.Zoom
-Percentage = _Percentage + 10
End With
End Sub

Sub ZoomOut()
With ActiveWindow.ActivePane.View.Zoom
.Percentage = .Percentage — 10
End With
End Sub

The next macro transforms the last typed (or selected) Latin letter to the corresponding Greek
letter of “Symbol” font (assign a convenient shortcut to the macro, like [CTRUHG]):

Sub ConvertToGreek()
IT Len(Selection.Range) = 0 Then Selection.Start = Selection.Start — 1
iCode = Asc(Selection)
Selection. InsertSymbol iCode - 4096, '"'Symbol™, True

End Sub

Paste clipboard content as unformatted text (e.g. [CTRUHSHIFTHV):

Sub PastePlainText()
On Error GoTo PasteError
Selection.PasteAndFormat wdFormatPlainText
End
PasteError:
MsgBox "Couldn®"t find any text on clipboard!"
End Sub

Open the most recently edited document (from the list of recent files) and locate the cursor at
the position where the document was last edited:

Sub ResumelLastDocument()
RecentFiles(1) .0pen
Application.GoBack

End Sub

Insert a sequential number prefixed with the chapter number (the macro asks for the name of
the sequence):
Sub InsertSequence()
sName = _
InputBox("'Type a name for the sequence', 'Sequence name', "Figure'™)
IT sName = """ Then Exit Sub
Selection.Fields.Add _
Selection.Range, wdFieldEmpty, "STYLEREF 1 \s", True
Selection.TypeText "-"
Selection._Fields.Add _
Selection.Range, wdFieldEmpty, "SEQ " & sName & " \s 1", True
End Sub

Update all fields in the document:

Sub UpdateAllFields()
Selection._WholeStory
Selection.Fields.Update
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Some useful macros

If ActiveDocument.TablesOfContents.Count >= 1 Then
For 1 = 1 To ActiveDocument.TablesOfContents.Count
ActiveDocument.TablesOfContents(i) .Update
Next 1
End If

IT ActiveDocument.TablesOfFigures.Count >= 1 Then
For 1 = 1 To ActiveDocument.TablesOfFigures.Count
ActiveDocument.TablesOfFigures(i) .Update
Next i
End If
End Sub
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